TG v3.0.0 Beta Released! - NemPosted: Jun 30th, 2003 - 2:35:01 pm

After over a year of sporadic programming it's finally out. This is a beta release but it seems to be pretty refined, there are a few minor bugs that I know about but overall the program is quite stable and should prove a huge upgrade from v2.3.0.

You can download the beta from here and post any comments, bug reports or suggestions here. Last but not least some random screenshot:

TG main screen.

Enjoy!

Modified: Mar 7th, 2004 - 4:47:20 pm[ 60614 Views ]

[ 1 2 3 4 5 ]

31. NemPosted: Jul 9th, 2003 - 3:03:15 pm

Hum, don't seem to have received it...

capoera

ryansgregg@hotmail.com

32. cdundePosted: Jul 9th, 2003 - 6:05:16 pm

Yes, the rel. 8 fix it fine. Thank you happy

I also downloaded the build 7 full install and ran that. the problem was NOT in that one, so is it also based on the fix?

One suggestion I have is, in QuArK they have it set up so you can zoom in and out by holding down both mouse buttons. I know you can pan by holding the right button, but it would be a nice feature for the 2 button zoom, rather then just the arrow keys, if it's not too much trouble. cool

Nice work, keep it up. yeahbaby

BTW, did you get the Addons menu zip I sent you for QuArK 6.4alpha?

33. SatchelPosted: Jul 10th, 2003 - 9:01:41 pm

Hey Nem,
I DL TG from File planet but...
I get an "app failed to initialize warning"

I am really excited to play with TG, Do you ahve another host?


34. SatchelPosted: Jul 10th, 2003 - 9:29:06 pm

BTW-- I also installed the latest build (8)
and I am running XP

35. SatchelPosted: Jul 10th, 2003 - 11:43:01 pm

Ahhh-- NM, forgot to intstall the MS.NET 1.1

Sorry about the space!

36. MolagPosted: Jul 11th, 2003 - 3:09:57 pm

I find that holding down the right click button for long periods of time really starts to hurt my hand...perhaps making a hotkey would make everyones hands hurt a lot less.

37. khazmodanPosted: Jul 12th, 2003 - 4:34:27 pm

Hi Nem, awesome program you made.

I got this error, donīt know if someone out there got the same one.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.DllNotFoundException: Unable to load DLL (nativegl.dll).
at TG.Engine.clsEngine.nglMakeCurrent(GLHandles* Handle)
at TG.Engine.clsEngine.ClearBuffers()
at TG.Engine.clsEngine.EnterRenderLoop()
at TG.Forms.frmTerraGen.NewFile()
at TG.Forms.frmTerraGen.cmdNew_Click(Object sender, EventArgs e)
at System.Windows.Forms.MenuItem.OnClick(EventArgs e)
at System.Windows.Forms.MenuItemData.Execute()
at System.Windows.Forms.Command.Invoke()
at System.Windows.Forms.Control.WmCommand(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll
----------------------------------------
TerrainGenerator
Assembly Version: 3.0.0.0
Win32 Version: 3.0.0.0
CodeBase: file:///C:/Arquivos%20de%20programas/Terrain%20Generator/TerrainGenerator.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
----------------------------------------
System
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
----------------------------------------
System.Drawing
Assembly Version: 1.0.5000.0
Win32 Version: 1.1.4322.573
CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
----------------------------------------

************** JIT Debugging **************
To enable just in time (JIT) debugging, the config file for this
application or machine (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the machine
rather than being handled by this dialog.

Iīm using an recent installed Windows XP with SP1, i download the last build TG 3.0 and i tried to run without the NET framework you mentioned with the download, them i got error and it even not opened a window, them i downloaded the NET framework and installed.
The program opens but it show this error.
I have an option to 'Quit' or 'Continue', them i try to create a New Terrain them the error msg appears again.
With the another Build you posted here i could put the Units and Size the Terrain is going to be, with the build on the downloads page the error cames before than it.

Sorry for the english.
=]

38. khazmodanPosted: Jul 13th, 2003 - 11:59:53 am

Sorry.
I already solved the problem.
=]

39. MasterChopChopPosted: Jul 14th, 2003 - 4:23:31 pm

Hey guys, it seems like im missing a nativegl.dll, what do i do?? i reall ywanna try version 3.00 of this. thanks for your time.

40. NemPosted: Jul 15th, 2003 - 8:01:16 am

You downloaded the patch, download the installer then overwrite the executable it installs with the patch.

41. SatchelPosted: Jul 15th, 2003 - 4:49:10 pm

Hey Nem,
Ive got a weird vis anomoly.
After exporting to rmf and cleaning up in Hammer, I checked the max view distance before compile to change it as usual from the 4096 to 8192. It was allready done so I presumed it was changed when it exported.
The problem is, vis still seems to be set to 4096 after the compile and test run. I've rechecked and recompiled 3 times, each time increasing the max vis distance by 4096 inits. It stays the same.

I havent had this prob with other maps without TG help. Do you know what could be causing this?brokenball

42. SatchelPosted: Jul 16th, 2003 - 12:25:39 am

BTW: I run ZHLT compiled on full vis.

I am going to compile with your batch compiler just for the hell of it.

43. SlackillerPosted: Jul 21st, 2003 - 8:14:42 pm

tg works great Nem apple



cool

44. NilhanthPosted: Jul 23rd, 2003 - 11:51:07 am

I have downloaded both the full terrain generator (build 7) and the patch (build 9). When i come to run it after installing it, it just comes up with this message:

"The Application Failed To Initialize Properly (0xc0000135). Click OK To Terminate The Application."

What Is Wrong???

45. NemPosted: Jul 23rd, 2003 - 12:13:43 pm

Do you have the .NET runtime on the Download page?

[ 1 2 3 4 5 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.027524s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π