TG v3.0.0 Beta Released! - NemPosted: Jun 30th, 2003 - 2:35:01 pm

After over a year of sporadic programming it's finally out. This is a beta release but it seems to be pretty refined, there are a few minor bugs that I know about but overall the program is quite stable and should prove a huge upgrade from v2.3.0.

You can download the beta from here and post any comments, bug reports or suggestions here. Last but not least some random screenshot:

TG main screen.

Enjoy!

Modified: Mar 7th, 2004 - 4:47:20 pm[ 38630 Views ]

[ 1 2 3 4 5 ]

1. DarkdruidPosted: Jun 30th, 2003 - 7:56:02 pm

That looks awsome, the water looks soo cool! I must see, I am downloading now!

2. FenderPosted: Jul 1st, 2003 - 2:38:07 am

I dled it, but I can't manage it to work in W2000 SP3.
It opens, but no "New" file can be created.
(A small windows opens, then closes immediately and I can't do anything 'cause everything is greyed out).
Please help.

3. mingoviaPosted: Jul 1st, 2003 - 6:00:32 am

I have the same problem as Fender. I am running Windows 98SE. I downloaded and installed TG v3.0.0.0. Before doing this I used Windows Update to get the latest .NET. Now, when I run TG, it comes up fine, but all of the buttons and menu items are greyed out. It will not even let me generate a new terrain.

4. YamazakiPosted: Jul 1st, 2003 - 10:20:08 am

Windows 2000 with SP3 and the dotnetfx installed. All the options are grayed out except for the File options. Basically the same result as Fender and mingovia.
alarmed

5. dok2rogPosted: Jul 1st, 2003 - 11:00:18 am

Yep, me too. im ready to go 'cept i cant..

6. xymerejxPosted: Jul 1st, 2003 - 11:55:25 am

I have the same problem, I Dled the new .net file from Windows and the program did load, but when I try to make a new file, nothing happens.

7. NemPosted: Jul 1st, 2003 - 12:36:53 pm

So am I right in saying that for most everyone here, when you press File->New a form pops up then closes before you can do anything?

This is most odd... TG was built on the .NET 1.0 framework so my best guess is that they have changed something in between releases (as most of you should have 1.1) that would cause this, and I think I might know what it is...

sad

8. NemPosted: Jul 1st, 2003 - 1:05:25 pm

OK, I've updated the exe, could someone please D/L it to make sure that this problem has been fixed?

On the same page as TG Beta's D/L I will be releasing periodic updated executables. Here is a direct link (124 KB Zipped).

9. FenderPosted: Jul 1st, 2003 - 3:06:29 pm

Just dled and overwrote.
IT'S FIXED!!!!

Thank you Nem

10. monkeygetModified: Jul 2nd, 2003 - 7:24:36 am

i tested this escellent soft and i found a few bugs and remarks:

-the little information box wich appear under the tools when u move the cursor on them (such as "start new terrain", "open saved game",....) those little information, when they are on the 3d view disapear.

-it would be really cool if "raise/lower" and "moutain/valley" could be used by moving the mouse such as smooth tool

-Smooth tool rarely work. Sometimes it works and the next time it doesn't. I don't know where it come from.

-In the texture browser, when u list a wad it take too much time to see the textures...i think that each time u list a wad .bmp are created no? it could be good to create the .bmp the first time u browse a wad, but not the next time (the best would be to recreate the .bmp once at each execution to prevent errors because of texture added/removed in the wad between execution).

-recent texture is resetted at each launch. Maybe could it be good to make them permanent (this could at least prevent the loose of time when textures of wad files are listed...(see above).

-For the terrain generator tool i thought that it was buggy cause it was generating always the same with slighty change. I don't know if it is but reset terrain should be activated by default... maybe is it only who messed with the tool...

-THE MOST ANNOYING BUG: when u move the view, and that u let the up or down arrow pressed for a second or two "Grid snap to size" @#&ing stop the move and is activated.

Sorry for my bad english...

I shall forgot: terrain generator is an incredible tool!!! can't wait to have smooth, 3dmove and the other bugs fixed!

11. NemModified: Jul 2nd, 2003 - 11:13:40 am

Hey, thanks for the feed back.

happy

- There isn’t too much I can do about the first item because this is mainly a video card issue (for example, my Radeon causes the text to flicker, but my Matrox G400 draws it perfectly).

- I’ll give that a try and possibly build in an option.

- The smooth tool only smooths as you move from quad to quad or (if you mouse is stationary) as you click your mouse.

- The texture browser seems to be reloading every time you open it (which it shouldn’t) I’ll look into it. If you have a large WAD open you can speed up the time it takes to view the WAD in the texture browser by splitting it up into sub directories. This can be done through WAD Directory Listing files (.wdl) which are located in your ‘Terrain Generator\config\wads\’ directory. To create one just create a text file and rename it <wadname>.wdl. You then just list the textures line by line grouped by braces as shown below:

Code:

dir=FolderName
{
tex1
tex2
tex3
}

You can also have recursive directories:

Code:

dir=FolderName
{
dir=FolderName
{
tex1
tex2
}
dir=FolderName
{
tex3
}
}
dir=FolderName
{
tex4
}

The easiest way to get a list of all the textures in a WAD file is with my wad2bmp program which can also dump all the names of the textures in a WAD file to a text file.

- Recent textures would be pretty easy to save.

- I can see why that would be confusing but the tool is designed for both generating starting terrain and adding features to your terrain and as such you should probably have to specify which you are doing.

- I have tried to reproduce your movement bug but have been unable to, could you give me step by step instructions on how to cause this bug? You can also use the WASD keys to move.

Again thanks for all the feedback.

12. HerBModified: Jul 2nd, 2003 - 1:06:24 pm

bug?? the raise/lower tool only make "blocks".

screenshot:
http://bugsbh.strikenet.at/huh.jpg

13. NemPosted: Jul 2nd, 2003 - 4:34:16 pm

Ya, that's what it is supposed to do...

Maybe I'll change it.

carryingstuff

14. FenderPosted: Jul 3rd, 2003 - 3:37:49 pm

Hint:
since ZHLT use Hint texture to reduce polycount,
what do you think about having all brushes created in TG with only the face... ehr facing the game textured with the texture tool while the other faces textured with zhlt.wad\HINT texture?

15. NemPosted: Jul 3rd, 2003 - 4:25:42 pm

I don't think you can mix hint and regular textures on a brush, and these extra faces will be deleted by the compiler during CSG anyways.

[ 1 2 3 4 5 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.045504s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π