Batch Compiler FAQ - NemPosted: May 26th, 2003 - 11:35:22 pm
Q.

When I launch Batch Compiler I get the following error message:
"The application failed to initialize properly (0xc0000135). Click ok to terminate the application."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I launch Batch Compiler I get the following error message:
"A required .DLL file, MSCOREE.DLL, was not found."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I open an old preset file I get the following error message:
"Error: The data at the root level is invalid. Line 1, position 1."

A.

Batch Compiler v3.X.X is not backwards compatible with Batch Compiler v2.X.X. This means that old preset files will not work and you will have to recreate them.

 
Q.

How can I convert a preset I've saved using one specification file to a preset of another specification file?

A.

This can be accomplished by importing the preset. To do this:

  1. From the 'Specifications' menu select the specification file you would like to convert the preset to.
  2. From the 'File' menu select 'Import Preset'.
  3. Browse to and open the preset you would like to convert from.

Ask a question...

Modified: Aug 5th, 2004 - 10:16:43 am[ 76401 Views ]

[ 1 2 3 4 5 6 7 8 9 ]

91. frankModified: Nov 6th, 2006 - 2:26:59 am
I have been trying my best to compile the map and I keep receiving this error message.

* Could not execute the command:
Copy File "C:\Valve\Condition Zero\czero\maps\Trial map"
* Windows gave the error message:
"Access is denied."

Can u provide me with a solutionsadsad

frank

92. SigPosted: Dec 6th, 2006 - 7:08:14 pm
I get this error right of way. Dont have any idea how to fix
Please Help!!!
I have NET 2.0

@echo off
echo ###################################################
echo # Batch Compiler #
echo ###################################################
echo ###################################################
echo # Please report bugs to: ryansgregg@hotmail.com #
echo ###################################################
echo.
echo Written At: 12/6/2006 5:48 PM
echo BC Version: 3.1.2.0
echo.
"D:\Program Files\Valve Hammer Editor3\hlcsg.exe" -wadautodetect -estimate "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars"
if ERRORLEVEL 1 goto failed
"D:\Program Files\Valve Hammer Editor3\hlbsp.exe" -estimate "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars"
if ERRORLEVEL 1 goto failed
"D:\Program Files\Valve Hammer Editor3\hlvis.exe" -full -estimate "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars"
if ERRORLEVEL 1 goto failed
"D:\Program Files\Valve Hammer Editor3\hlrad.exe" -extra -bounce 1 -sky 0.5 -smooth 80.0 -sparse -estimate "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars"
if ERRORLEVEL 1 goto failed
if ERRORLEVEL 1 goto failed
goto succeeded
:failed
echo.
echo There was a problem compiling your map, check your pillars.log file for errors.
:succeeded
echo.
if exist "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars.log" "D:\WINNT\SYSTEM32\notepad.exe" "D:\Documents and Settings\Administrator\Desktop\Maps\pillars\pillars.log"

93. wrexnfexPosted: Dec 7th, 2006 - 3:21:39 am
when I try to compile my map i get an error

hlbsp: Error: Cant open as_wrex.po

how do i fix

94. NemPosted: Dec 10th, 2006 - 4:28:43 pm
Sig:
I get this error right of way. Dont have any idea how to fix

What you've posted is your batch file, not your error log.

wrexnfex:
when I try to compile my map i get an error

hlbsp: Error: Cant open as_wrex.po

how do i fix

Sounds like there was an error in hlcsg.

However, neither of these errors are bugs in Batch Compiler, I recommend that both of you try the VERC forums for general mapping problems where you'll get a faster more appropriate response.

95. SigPosted: Dec 13th, 2006 - 3:53:40 pm
I dont get an error log I have looked for it everywhere. So what I posted is all I get.

96. atelierzModified: Jul 17th, 2007 - 1:08:16 pm
i have just installed batch compiler on my new machine, which is running on vista.

i haven't gotten to the point of compiling just yet, so i can't speak to its stability, but i have noticed that in the source tools advanced and source tools normal specifications, there is no tick box for ldr/hdr.

i have used your tool pretty extensively in the past on my xp machine, and while i've never compiled under hdr, the option was always there.

this is the only option i am really concerned with, but i notice, in comparing what i have up right now with the tutorial you provide, that there are some other options missing, as well...

as far as i can see, under RAD, they are:

soft sun, chop, and max chop.

i hope in the end that i can run compiles from your tool in vista, but for now, do you have any idea why these options wouldn't be appearing.

btw, i have gone back several times and followed the tutorial in case i had missed a step.

thanks in advance, and thanks for the tool...hope i can continue using it.

97. BluefangPosted: Jul 17th, 2007 - 11:18:46 pm
I haven't been keeping up with everything very well, but I do know that Nem changed the spec files recently, so the options may have been renamed or moved.

98. NemPosted: Jul 18th, 2007 - 3:18:38 am
Do you have the most up-to-date specifications? (Select Check For Updates from the Help menu.) I haven't updated the installer in ages (I'll try to do this soon).

The options haven't changed too much since I wrote the tutorial. All the options you listed are present in the current specifications.

99. atelierzModified: Jul 18th, 2007 - 1:05:46 pm
i had downloaded straight from the site thinking everything was up to date, but i took your advice, and the options reappeared. hooray.


however, when i tried to compile, i got this error:
error wirting batch file: c:\prgram files\batch compiler\compile.bat

i went back through the setup again, and everything is as it should be, except that when i press the associate with BCP files button, i get this error message:
an unhandled exception has occured in your application. if you click continue, the application will ignore this error and attempt to continue. if you click quit, the application will shut down immediately. access to the registry key is denied.


and then here are the details of that:



************** Exception Text **************
System.UnauthorizedAccessException: Access to the registry key is denied.
at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
at Microsoft.Win32.RegistryKey.SetValue(String name, Object value)
at BC.Core.GUI.COptions.AssociateFileType(String sFileType, String sExtension, String sApplicationPath, String sIconPath, Int32 iIconIndex)
at BC.Core.GUI.COptions.AssociateFileType(String sFileType, String sExtension, String sApplicationPath)
at BC.Core.GUI.COptions.btnAssociateWithBCPFiles_Click(Object sender, EventArgs e)





i'm sure that the chances are just as good that i'm being an idiot with this, but i am just so frustrated with vista's backward compatibility at this point that i have very little patience.exhausted


thanks

100. NemPosted: Jul 18th, 2007 - 2:23:04 pm
I don't actually own Vista, but I would assume that the errors are occurring because writing to the registry and the program's own directory is not allowed with user privileges in Vista. I wonder if you can elevate the program's privileges (the executable's properties perhaps)? I don't want to recommend that you give your user account administrative privileges, but that also should work.

capoera

101. atelierzModified: Jul 18th, 2007 - 5:18:06 pm
i've run into this administrative privileges thing before, and upon checking my account on this computer, it says i have administrative privileges.

why wouldn't you recommend admin on my own machine? i thought vista sorted out the drive by problems that xp had with admin accounts.


thanks for your quick responses. i know this is more a vista problem and a me problem than your problem, but you've been gracious about it, anyway.

102. atelierzPosted: Jul 18th, 2007 - 5:17:23 pm
okay, i figured it out.

even though i'm logged on as admin, it apparently doesn't allow me access to the registry by default. i right clicked on the file and selected "run as administrator" and i'm no longer having any issues.

the map is compiling now. hopefully you won't have to hear from me about vista again.

thanks again for the tool and your time. it's a huge help.

103. magraggaeModified: Nov 14th, 2007 - 6:01:56 am
This is my first time trying to get BC to work, set it up under Zoners' Tools Advanced Specification, as I am using VHE, and got an rmf and not an map file. Except for that I used the exact same setup as you described in your tutorial. When I compile my map using VHE, it completes without problems.

When I compile it with BC I get:
Warning: Illegal Brush (edge without opposite face): Entity 134, Brush 1


The specified brush is an func_illusionary What is exactly wrong with the brush, what does this specific error mean?

Besides that, I also get a leak if I compile with BC, trying to track it down atm.
EDIT: Basically, the leak is unfindable. I have tried boxing the map and tracking it down with successive smaller boxes, but every time I track one down, another one pops up, and besides, the one tracked down in a 32x32x32 box has no discernible leak, everything lines up.
I copied a part of my map to a new file, and the specified brush stopped being illegal, and another brush, a func button started being illegal for another reason....What am I doing wrong with BC, as VHE says everything is fine but then everyone knows vhe a shit compiler, but what explains the differences?

104. NemPosted: Nov 15th, 2007 - 1:29:30 am
There are a few good references for compile errors out there such as this one. You'll probably get a more direct answer from these references seeing as I use them myself.

A great many of us have been stumped by leaks in the past, but they always turn out to be tangible. Have you tried tracing the pointfile yet? As for discrepancies between Hammer and Zoners Tools, Hammer can only find certain simple errors, so your map may still have errors even if Hammer reports that everything is fine.

105. magraggaeModified: Nov 15th, 2007 - 6:55:19 am
Yeah I checked those resources myself already, however this error is not listed there. As far as I can see, there is nothing wrong with the brush. Its a simple cubic brush, clipped on one end so it meets at 45 degree angle with another one, also clipped, to together form a func_illusionary, to create a fence, through which can still be shot. No vertex manipulation was done on it, so I am unsure what could be illegal about it.

Well about the leak, still have not found it, I copied the corridor to a new rmf, and trying to find it, but I still am unable to find it. I loaded the pointfile, the line goes straight through a brush, which is not an entity. Besides that, the other lines are outside. I tried boxing my lvl and putting a very bright light inside, but it appears the light just goes right through cause it was the same brightness inside or outside my hallway.

"To begin with, hlfix outputs floating point coordinates to .map files as opposed to VHE which rounds all coordinates to integers. This alone solves a number of typical mapping problems. hlfix also performs three phases of geometry corrections"
Guess it must be related to this, probably some where on my design, I got something offgrid, and VHE just rounds it to an integer, making it snap to the grid, while hlfix keeps it offgrid.
Think is, I am pretty sure I already exported it through vhe and skipped the hlfix stage once.

[ 1 2 3 4 5 6 7 8 9 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.062217s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π