Batch Compiler FAQ - NemPosted: May 26th, 2003 - 11:35:22 pm
Q.

When I launch Batch Compiler I get the following error message:
"The application failed to initialize properly (0xc0000135). Click ok to terminate the application."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I launch Batch Compiler I get the following error message:
"A required .DLL file, MSCOREE.DLL, was not found."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I open an old preset file I get the following error message:
"Error: The data at the root level is invalid. Line 1, position 1."

A.

Batch Compiler v3.X.X is not backwards compatible with Batch Compiler v2.X.X. This means that old preset files will not work and you will have to recreate them.

 
Q.

How can I convert a preset I've saved using one specification file to a preset of another specification file?

A.

This can be accomplished by importing the preset. To do this:

  1. From the 'Specifications' menu select the specification file you would like to convert the preset to.
  2. From the 'File' menu select 'Import Preset'.
  3. Browse to and open the preset you would like to convert from.

Ask a question...

Modified: Aug 5th, 2004 - 10:16:43 am[ 142415 Views ]

[ 1 2 3 4 5 6 7 8 9 ]

61. BossmanPosted: Jan 26th, 2006 - 11:16:05 pm
My Appologies, i believe i mis worded my question.

I am using 2 wads halflife wad and a cusom wad.

Seems how everyone that plays half life already has the first, i only need to include whats been used in the second.

Is that possible?

Thank You

62. NemPosted: Jan 26th, 2006 - 11:36:50 pm
Yes, just select your custom .wad in one of the WAD File fields in the CSG tab. Do not select No WAD Textures.

63. BossmanPosted: Jan 27th, 2006 - 1:10:52 pm
Thank You, Greatly appreciated.

I have been extremely pleased with BC since I have started using it a few days ago.

64. EvilPosted: Mar 1st, 2006 - 9:49:53 am
i have a map that i try to compile and it wont work cause of i have something called max switchable light enteties?????????

im trying to make the map so you switch sides every round. it works fine when i compile it in valvehammer and it all works.

but when i use batch.. it wont compile at all

heres the log:



hlcsg v2.5.3 rel Custom Build 1.7 (Dec 9 2002)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (merlinis@bigpond.net.au)
----- BEGIN hlcsg -----
Command line: "C:\Documents and Settings\Mats\Skrivbord\allt Andreas\Ny mapp\hlcsg.exe"-noskyclip -wadinclude tractor.wad -wadinclude czcs_militia.wad -wadinclude halflife.wad -wadinclude czde_dust.wad -wadinclude torntextures.wad -wadinclude czcs_office.wad "C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.map"
Entering C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.map

Current hlcsg Settings
Name | Setting | Default
---------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
null texture stripping[ on ] [ on ]
clipnode economy mode [ on ] [ on ]
onlyents [ off ] [ off ]
wadtextures [ on ] [ on ]
skyclip [ off ] [ on ]
hullfile [ None ] [ None ]
min surface area [ 0.500 ] [ 0.500 ]
brush union threshold [ 0.000 ] [ 0.000 ]

Using mapfile wad configuration
Wadinclude list :
[zhlt.wad]
[tractor.wad]
[czcs_militia.wad]
[halflife.wad]
[czde_dust.wad]
[torntextures.wad]
[czcs_office.wad]

54 brushes (totalling 324 sides) discarded from clipping hulls
CreateBrush:
(37.95 seconds)
SetModelCenters:
(0.12 seconds)
CSGBrush:
(10.89 seconds)
Error: Exceeded MAX_SWITCHED_LIGHTS
Description: The maximum number of switchable light entities has been reached
Howto Fix: self explanitory


----- END hlcsg -----



hlbsp v2.5.3 rel Custom Build 1.7 (Dec 9 2002)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (merlinis@bigpond.net.au)
----- BEGIN hlbsp -----
Command line: "C:\Documents and Settings\Mats\Skrivbord\allt Andreas\Ny mapp\hlbsp.exe""C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.map"
>> There was a problem compiling the map.
>> Check the file C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.log for the cause.

----- END hlbsp -----



hlvis v2.5.3 rel Custom Build 1.7 (Dec 9 2002)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (merlinis@bigpond.net.au)
----- BEGIN hlvis -----
Command line: "C:\Documents and Settings\Mats\Skrivbord\allt Andreas\Ny mapp\hlvis.exe"-full "C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.map"
>> There was a problem compiling the map.
>> Check the file C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.log for the cause.

----- END hlvis -----



hlrad v2.5.3 rel Custom Build 1.7 (Dec 9 2002)
Zoner's Half-Life Compilation Tools -- Custom Build
Based on code modifications by Sean 'Zoner' Cavanaugh
Based on Valve's version, modified with permission.
Submit detailed bug reports to (merlinis@bigpond.net.au)
----- BEGIN hlrad -----
Command line: "C:\Documents and Settings\Mats\Skrivbord\allt Andreas\Ny mapp\hlrad.exe"-lights "C:\Documents and Settings\Mats\Skrivbord\mappar\Ny mapp\andreas.rad""C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.map"
>> There was a problem compiling the map.
>> Check the file C:\Documents and Settings\Mats\Skrivbord\dw_d-day\dw_d-day.log for the cause.

----- END hlrad -----




65. BluefangModified: Mar 1st, 2006 - 10:20:43 am
First of all, you are not using the most recent compile tools.
get them here:

http://www.ammahls.com/forum/viewtopic.php?t=81

Second, you are wadincludeing wads that should not be included. do not include the halflife.wad or any other standard WAD that comes included with the mod you are mapping for.

Third, the error means that you have too many switchable light entitys shining on any given face. Theese can be light entitys are are triggered by a switch or switchable texture lights. I seem to recall te maximum allowed was 4 shining on any individual face.

Basicaly, you have too many lights that illuminate a particilar part of the map that can be individually switched on and off. If you want to have many lights turn on and off at once, make them all have the same properties (target name, style ect... the color can be difrent).


And just FYI, this really isn't the place to be posting compile errors. first check out:
http://www.slackiller.com/tommy14/errors.htm
and if all else fails, these are the forums to look at:
http://www.chatbear.com/board.plm?b=390

66. evil squirrelPosted: Mar 11th, 2006 - 1:18:29 pm
Question...about a very annoying thingeh

Heres how it goes, I open Batch Compiler (which i just downloaded), set all the presets as I assume they should be, put the location of the VMF file I'm trying to compile in the bar (with remember file and run), and hit Run.

Error creating batch script.

Error: Output path is not set or is invalid.


And when i try to compile it with hammer, it just says it could not locate the file (after telling me exactly where the file is).

67. NemPosted: Mar 11th, 2006 - 1:21:45 pm
Did you read the appropriate setup tutorial?

68. atxaaronPosted: Jun 19th, 2006 - 11:23:57 pm
Nem, I have done everything your tutorial told me to do but I get this error, "error executing batch file". A few months back I had this tool on a different computer and it worked, so I am firmiliar with the program.

69. NemPosted: Jun 20th, 2006 - 8:35:01 pm
The error occurs when the system is unable to execute the batch file. Make sure you have your .bat files correctly associated and set up to run in the Windows shell.

70. atxaaronPosted: Jun 21st, 2006 - 5:20:01 am
Sorry nem, I dont understand, what do I need to do? windows shell?
Before I posted her i tried reinstalling it a few times.

71. NemPosted: Jun 21st, 2006 - 11:27:00 pm
When you double click a .bat file (or any other file) the Windows shell determines which program should be used to run that file. When you run a batch from Batch Compiler, Batch Compiler generates a .bat file and asks the Windows shell to run it. The error you are receiving occurs when Windows doesn't know what to do with the .bat file, likely because something has changed in your settings.

72. LightningBoyPosted: Jun 22nd, 2006 - 7:11:59 am
On the "Variable" stage of the setup for BC, I have set this to point to the location of the game folder that contains the gameinfo.txt file for that game. In this instance, - DOD:Source.
Everything else is setup just fine.
When I attempt to compile, I get a vbsp error "Entrypoint teir0" or something very similar. I click ok several times before the dialogue box dissapears, and am left with a message in the compile log
"Can't load materialsystem"

When I have the variable stage pointing to the Gameinfo.txt file in the HL2 folder, It compiles normally, except the necessary DOD materials aren't available,....cause it's not look'n in the DOD:S dir.
"can't load <material name>",........etc.

I also tried running animahls customtools,....but I get a different error when combined with either the dod variable, or the HL2 setting
"Extra App set to 211, but no SteamApp ID"

Seen this before?

I guess I could just put the materials I want to use in the appropriate HL2 Materials folders, ...but shouldn't it work by looking for the proper Gameinfo.txt file for DOD? where

LB

73. DysPatchPosted: Jun 23rd, 2006 - 8:15:17 pm
Yeah, i am getting the same thing for Counter-Strike Source.

I think it has something to do with the new Source update.

Someone please figure this out, because the in Hammer compiler sucks. It keeps freezing on me at the end of portal flow. PLEASE HELP.

74. atxaaronPosted: Jun 28th, 2006 - 2:50:08 pm
Nem, im still stuck, I need like steps on how to fix this, im a complete newb at what your trying to tell me to do. ahhh!?!?!=( the hammer compiler sucks!

75. LightningBoyPosted: Jun 28th, 2006 - 5:46:42 pm
I'm guessing no one else has had this problem besides DysPatch and myself?
Anyone have a cure?,...suggestion?
I haven't had a successful compile yet because of this.

[ 1 2 3 4 5 6 7 8 9 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.035167s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π