Batch Compiler FAQ - NemPosted: May 26th, 2003 - 11:35:22 pm
Q.

When I launch Batch Compiler I get the following error message:
"The application failed to initialize properly (0xc0000135). Click ok to terminate the application."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I launch Batch Compiler I get the following error message:
"A required .DLL file, MSCOREE.DLL, was not found."

A.

Batch Compiler is written in C# .NET and such as requires the .NET runtimes to run. See the downloads page for more information.

 
Q.

When I open an old preset file I get the following error message:
"Error: The data at the root level is invalid. Line 1, position 1."

A.

Batch Compiler v3.X.X is not backwards compatible with Batch Compiler v2.X.X. This means that old preset files will not work and you will have to recreate them.

 
Q.

How can I convert a preset I've saved using one specification file to a preset of another specification file?

A.

This can be accomplished by importing the preset. To do this:

  1. From the 'Specifications' menu select the specification file you would like to convert the preset to.
  2. From the 'File' menu select 'Import Preset'.
  3. Browse to and open the preset you would like to convert from.

Ask a question...

Modified: Aug 5th, 2004 - 10:16:43 am[ 165909 Views ]

[ 1 2 3 4 5 6 7 8 9 ]

121. StojkePosted: May 9th, 2010 - 8:17:05 am
Hey, Nem, i have some problems...

Every time i try to compile a map (i never have ever gotten this error before) i get this:

Submit detailed bug reports to (amckern@yahoo.com)
----- BEGIN hlcsg -----
Command line: "D:\Back up 22\Valve Hammer Editor\zhlt34x86final\hlcsg.exe"-nowadtextures -wadinclude decals.wad -wadinclude halflife.wad -wadinclude liquids.wad -wadinclude zm_snowbs02.wad "C:\Documents and Settings\Stojke\Desktop\zm_snowbase_cla"
Entering C:\Documents and Settings\Stojke\Desktop\zm_snowbase_cla.map

Current hlcsg Settings
Name | Setting | Default
---------------------|-----------|-------------------------
threads [ 1 ] [ Varies ]
verbose [ off ] [ off ]
log [ on ] [ on ]
developer [ 0 ] [ 0 ]
chart [ off ] [ off ]
estimate [ off ] [ off ]
max texture memory [ 4194304 ] [ 4194304 ]
max lighting memory [ 6291456 ] [ 6291456 ]
priority [ Normal ] [ Normal ]

noclip [ off ] [ off ]
null texture stripping[ on ] [ on ]
clipnode economy mode [ on ] [ on ]
clip hull type [ legacy ] [ legacy ]
onlyents [ off ] [ off ]
wadtextures [ off ] [ on ]
skyclip [ on ] [ on ]
hullfile [ None ] [ None ]
nullfile [ None ] [ None ]
min surface area [ 0.500 ] [ 0.500 ]
brush union threshold [ 0.000 ] [ 0.000 ]

Using mapfile wad configuration
Wadinclude list :
[zhlt.wad]
[decals.wad]
[halflife.wad]
[liquids.wad]
[zm_snowbs02.wad]

2 brushes (totalling 12 sides) discarded from clipping hulls
CreateBrush:
(0.33 seconds)
SetModelCenters:
(0.02 seconds)
CSGBrush:
(1.19 seconds)

Warning: Wad file '\decals.wad' not found
Warning: Wad file '\halflife.wad' not found
Warning: Wad file '\liquids.wad' not found
Warning: Wad file '\zm_snowbs02.wad' not found
Error: Could not open wad file \decals.wad
Error: Could not find WAD file
Description: The compile tools could not locate a wad file that the map was referencing.
Howto Fix: Make sure the wad's listed in the level editor actually all exist

Error: Could not open wad file \halflife.wad
Error: Could not open wad file \liquids.wad
Error: Could not open wad file \zm_snowbs02.wad


I have tried moving the wads, and everything. All the wads exist, and are on the right path. But the compiler tools tell me they can not find them... bored

122. StojkePosted: May 9th, 2010 - 8:27:30 am
Never mind! I forgot to include zhlt.wad in hammer >_<


Sorry for my mistake lazy

123. PlaguePosted: Jul 3rd, 2019 - 7:40:33 pm
When I try to convert a batch file to an exe, I have this error at the end:

Injecting Icon...
Cannot Make EXE!
Bad file name or number
Please make sure ENGLISH is your primary language for "non-unicode programs" on your Windows Language bar or control panel.

I don't understand, my computer is in english and all seems good.. I tried all the available update but nothing works

[ 1 2 3 4 5 6 7 8 9 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.027346s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π