Adding Preset 'Quick Launch' Buttons (Half-Life) - NemPosted: May 26th, 2003 - 10:42:46 pm

If you are coming from the Creating A Preset tutorial then you should be all set to add your "Full" preset to the Presets menu; otherwise, if you have not created a "Full" preset, please see the Creating A Preset tutorial.

To add a preset to the Presets menu we must first head back to the options form. In the Options menu click Setup. Next click on the Presets tab. It should look like this:

Options Form - Presets Tab

Now click the Add button and browse to the location you saved your preset to, select it, and open it. The preset will now be added to your list of presets as shown below:

Options Form - Paths Tab

You can add as many presets as you want here, and remove them latter by simply selecting them and clicking the Remove button. Once you are happy with the presets you have added, click OK to return to the main Batch Compiler from. You'll now notice a shinny new Presets main menu option. From here you can launch any presets you added from the options form. It should look like this:

Batch Compiler Form

You can pick up a pack of three common preset files here. This includes presets for fast, normal, and full compiles.

Modified: Mar 24th, 2005 - 6:15:30 pm[ 23954 Views ]

[ 1 2 ]

1. NemPosted: Jun 5th, 2003 - 9:10:25 pm

A lot of people are always asking me what good settings for a full compile are, so if you haven't noticed the like to sample preset files yet, look directly above this post.

capoera

2. madman_12004Posted: Oct 3rd, 2003 - 6:11:15 am

one thing im new to this and i was wondering if you need to have Half life.where

3. NemPosted: Oct 3rd, 2003 - 3:49:39 pm

As in will it work for CS retail? Yes it will, just change the appropriate paths (i.e., instead of hl.exe use cstrike.exe).

4. mykel_suthertunPosted: Oct 16th, 2003 - 3:02:36 pm

I used to compile in Worldcraft but it has since stopped working with my map, so I downloaded your compiler. I followed the tutorial exactly, and even downloaded the Full preset and used it to compile my map. It worked, however there are no shadows in my map at all like there used to be. How can I fix this?

5. rexbronPosted: May 26th, 2004 - 4:57:30 pm

I have not been able to find a tutorial on how comple in 1.6 and then launch right in to it. I was wondering if any one knew how?

6. DeadManPosted: Jul 18th, 2004 - 10:38:36 pm

i have every thing set up just as above but i get this in the log file.....
----------------------------------------------------
Error: Entity 0, Brush 439, Side 1: has a coplanar plane at (2984, 1808, 384), texture METALSKIN1
Error: Entity 0, Brush 439: outside world(+/-4096): (-1658,-7165,-10000)-(7798,10459,10000)
Error: Entity 0, Brush 439: outside world(+/-4096): (-1658,-7165,-10000)-(7798,10459,10000)
Error: Entity 0, Brush 439: outside world(+/-4096): (-1658,-7165,-10000)-(7798,10459,10000)
----------------------------------------------------
can anyone help or head me in the right direction??

thanx

7. NemPosted: Jul 19th, 2004 - 10:25:38 am

You have BC set up right, but any errors you get compiling are errors with your map, not BC. See this page.

8. DeadManModified: Jul 20th, 2004 - 10:57:05 am

Code:
This error is always caused by vertex manipulation.
A plane is defined by 3 unique coordinates. If any of the three
coordinates are the same, then you don't really have a plane (its
either a line or a point).
There is no way to fix this error other than to delete the brush and
recreate it completely.

im taking it that the surfaces must be cbes,hex,etc. and cant have 2 sides..

9. neo-interactivePosted: Sep 6th, 2004 - 8:28:12 pm

Error: Can't open c:\windows\desktop\neo-map\index.p0



i get this error when compiling my map!!!!bleeh

10. neo-interactivePosted: Sep 6th, 2004 - 8:29:37 pm

i get another error too

the file is invalid or not set!

c:\programsfiles\valvahammereditor\compiler.bat

11. squirtlePosted: Dec 11th, 2005 - 2:27:48 pm
i have a question. i got my map to work but after i almost threw my computer accross the room. i keeped getting a light error it said to add lights. well i had some so i thought maybe i need more, and thew lights all over the place and then the compile just had a quick dos popup window comes up and goes away and nothing happens. so i took a screenshot and saw it said unknown option "-cliptype" so i went to the csg tab and unchecked cliptype and it compiled fine. what am i doing wrong that cliptype had to be unchecked?

12. NemPosted: Dec 11th, 2005 - 11:55:40 pm
The switch isn't working because the version of Zoner's Tools that you have is out of date. See this page for more info.

13. squirtlePosted: Dec 15th, 2005 - 9:57:29 pm
are u entirly sur about that because I tried that. and another thing, the tools from "Zoners Tools Legacy (v2.5.3)" in the archive mapping tools u have for download didnt work eather but i got another version called zhlt253-17. not sure if thats same version but thoes tools work but like i said, i have to uncheck cliptype. can u specify what versions are compatible. im using valve hammer/worldcraft 3.4 and batch compiler 3.1.2.

14. NemModified: Dec 16th, 2005 - 12:55:39 pm
Here is a better link. According to that link, the latest tools (v3.3) support the cliptype parameter. If they don't, please let me know and I'll update the specification. It is had for me to keep track of all the changes to the tools on top of everything.

The cliptype switch isn't essential as long as you aren't running out of clip nodes, so if you aren't, you can safey ignore it.

15. BluefangModified: Dec 16th, 2005 - 3:05:51 pm
The cliptype option is only in zhlt 2.5.3m1.7p3 (I guess that's the full name). That means any of the really old tools (zhlt 2.5.3 and before), semi-old tools (mhlt 1.7 and before) and earl chlt builds don't have the clip type options. The option was introducex in XP-Cageys 'P' series. See the version history if you don't beleive me.

If you want to use the cliptype option, your best bet is a version of ZHLT 3. Like Nem siad, unless you are having clipping problems, you shouldn't even need to use this option. However, if you are using ZHLT 3+, I suggust using cliptype precise if it dosn't cause you any error.

[ 1 2 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.032807s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π