virtuAMP FAQ - NemPosted: Jul 4th, 2007 - 3:13:10 pm
Q.

How do I connect my guitar to my computer?

A.

There are two cheap solutions to this question:

  1. Obtain a 1/4" (6.35 mm) mono to 1/8" (3.5 mm) mono adapter. Such adapters are available at most good audio/video stores. A stereo adapter should also do the job. You should then be able to connect a standard 1/4" guitar cable into the 1/8" line-in or microphone input on your computer. Play as usual using either headphones or speakers.
  2. Obtain a microphone and a set of headphones, connect your microphone to your computer's microphone input and your headphones to your computer's headphone output. Play into your microphone.
Q.

Why do my speakers pop when I play my guitar through virtuAMP?

A.

Your computer isn't able to process audio buffers fast enough before receiving the next audio buffer. This is usually caused by a slow CPU or cheap sound card. You can mitigate the effect by trying any combination of the following three settings:

  1. Audio Driver: Try switching between the Windows Multimedia and DirectSound audio drivers. The DirectSound audio driver should provide better priority for audio processing, but requires Windows XP and up.
  2. Audio Buffer Denominator: Try increasing the delay between audio buffer capture and playback by decreasing the audio buffer denominator setting one step at a time. Allow a few seconds to determine effectiveness.
  3. Audio Buffer FPS: Try decreasing the display frame rate by decreasing the audio buffer FPS setting. This will provide more CPU time for audio processing.
Q.

How do I connect foot pedals to virtuAMP?

A.

virtuAMP does not support foot pedals, but you can use your keyboard to toggle effects on and off. To add a shortcut:

  1. Select an effect.
  2. While holding the shift key, press the button you wish to use to toggle the effect (you can assign the same key to multiple effects).
  3. The name of the key you selected should appear in the status bar at the bottom of your screen.
  4. Repeat 1-3 for each effect you with to add a shortcut to.

To remove a shortcut:

  1. Select an effect.
  2. While holding the shift key, press delete.
  3. Repeat 1-2 for each effect you with to remove a shortcut from.
Q.

Why can't the Player/Recorder effect play my .wav file?

A.

virtuAMP only supports 8 or 16 bit PCM, and 32 bit or 64 bit IEEE floating point .wav files sampled at 44100 Hz.

You may use Audacity to convert your .wav files to an accepted format.

You may also encounter problems if the .wav file is opened in another program, or by virtuAMP for recording. Check the log.txt file in your installation folder for detailed error messages.

Q.

How do I improve my sound quality?

A.

virtuAMP is not meant to be a replacement for real guitar amplifiers or professional studio equipment. Having said that, there are many factors that will affect the quality of sound virtuAMP can produce. Your audio card and speakers are probably the most important factors (most computers come with a cheap on-board sound card), and a slow CPU can lead to audible popping as audio buffers aren't processed before they are needed. Upgrading any of these things may lead to a better overall sound.

Ask a question...

Modified: Sep 4th, 2007 - 8:15:19 pm[ 16855 Views ]

[ 1 2 ]

1. SheepdogPosted: Aug 10th, 2007 - 6:49:52 pm
Does this support Vista (32-bit) fully?

I have it installed and I have my guitar set up right, but what next? Does it just automatically alter your sound? Because nothing happens and when I try to use the "Mute" button it stops responding. Did I miss something?

2. NemPosted: Aug 10th, 2007 - 9:41:37 pm
If the application is working, you should just hear sound. I haven't tested virtuAmp in Vista, but by the sounds of it, it may not work. I'll try to fix this soon (I'm in the middle of my final exams at the moment).

3. SheepdogPosted: Aug 11th, 2007 - 8:35:29 pm
Alright thanks. And what I have seen of the program it looks great. If it sounds as good as it looks, then I'm sure you've made a damn good program ;)

And good luck with the exams...

4. leezanoniPosted: Aug 16th, 2007 - 2:24:01 pm
I downloaded the program but it will not produce any sound i can hear the pedals buzzing but no sound

when i use my recording software it will pick up the guitar but i really want to be able to use all those pedals.

i dont no what i am doing wrong i tried the buffer setting fom 1 to 18 and it makes no difference

please help

thank you

lee

5. NemPosted: Aug 16th, 2007 - 3:40:36 pm
What OS are you on? Can you post the contents of log.txt (found in your virtuAMP folder)? You may also try checking your microphone volume using the Windows Volume Control utility.

Other than that, I'm not too sure. I'll hopefully be releasing a new version in the next week or so with better audio support through DirectX. I'll also be taking a look at the current audio driver, which is based on the Windows Multimedia API, as it may have problems with Vista.

lazy

6. leezanoniPosted: Aug 16th, 2007 - 4:01:51 pm
this is what my log says


Initializing engine...
Engine initialized.
Creating new pedalboard...
Pedalboard cleared.
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/preamp.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/preamp.png loaded (256x256 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/power.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/power.png loaded (8x8 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/knob.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/knob.png loaded (32x32 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/output.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/output.png loaded (64x32 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/noise gate.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/noise gate.png loaded (256x256 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/input.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/input.png loaded (64x32 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/equalizer.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/equalizer.png loaded (256x256 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/slider.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/slider.png loaded (8x8 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/oscilloscope.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/oscilloscope.png loaded (256x256 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/speaker cabinet.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/speaker cabinet.png loaded (256x256 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/cable head.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/cable head.png loaded (32x32 @ 4 BPP).
Loading C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/cable shell.png...
C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\units/cable shell.png loaded (32x32 @ 4 BPP).
New pedalboard created.
Destroying engine...
Pedalboard cleared.
Engine destroyed.
Saving C:\Documents and Settings\Admin\Local Settings\Temp\virtuamp100\virtuAMP\virtuAMP.ini...

7. leezanoniPosted: Aug 16th, 2007 - 4:20:29 pm
my os is win xp

8. NemPosted: Aug 27th, 2007 - 4:40:04 pm
Just an update for those interested: I've got virtuAMP working under Vista now, and I've added new Flanger and Feedback Loop effects. Once I finish up DirectSound support and a new Fuzz pedal I'll upload the next release. I expect this to be within a week.

9. mabanPosted: Aug 27th, 2007 - 11:06:55 pm
Cool!

10. ZzzyaxPosted: Sep 4th, 2007 - 1:46:53 pm
...I should have read this before i made the question on the About page, oh well... i know now...

11. MisFit4MePosted: May 20th, 2008 - 4:36:26 pm
Is there a way to play through VituaAMP but record in Audacity? I record music mostly in Audacity and it'd be cool if there were a way for me to play using virtua amp and it record what came out into Audacity. Let me know if there's an easy way to do this.

12. NemPosted: May 20th, 2008 - 6:21:12 pm
Usually you can set your recording input to be the stereo mix, but because you need your recording input to be your mic or line in for virtuAMP, I can't think of any way to do this.

capoera

You can, however, use virtuAMP's Recorder pedal to record what you play to a .wav file, then open the .wav file in Audacity.

13. MisFit4MePosted: May 21st, 2008 - 5:31:00 pm
I was trying to do that but I couldn't seem to get it to work. How does the recorder pedal work exactly? It seemed that when I used it, the "power" light wasn't on.

14. NemModified: May 21st, 2008 - 6:19:12 pm
Works fine with Audacity (I've used the two several times). To use it:
  1. Place the pedal wherever you want to record (usually before the speaker cabinet).
  2. Press the save button and select a file to record to.
  3. Engage the pedal to record to the file (each time you engage the pedal it overwrites the file's contents).
  4. Play your guitar.
  5. Disengage the pedal to stop recording.

15. philipearlwilliamsPosted: Feb 4th, 2009 - 3:55:40 am
i am using windows vista 32 bit....the program works but there is a delay between the note played and the sound output to the speakers ? is this something that you are working on or will work on. this is going to be a great program once this little glitch is fixed. thank you for taking the time to build this app. good luck !

[ 1 2 ]

You must be logged in to post a comment.
New users can register here.
Nem's Tools v2.0 © 2006 Ryan Gregg.
Execution time: 0.024057s; Queries: 17.
dishes served.
Powered by The Wavelength.

Valid XHTML 1.0 Transitional Valid CSS
π